Welcome Guest! To enable all features please Login or Register.



Go to last post Go to first unread
Offline Robert Walter  
#1 Posted : Thursday, October 27, 2011 1:13:02 PM(UTC)
Robert Walter

Joined: 8/24/2011(UTC)
Posts: 68

Thanks: 4 times
I'm encountering a problem with the mouse input right now.
In my application I'm using some mouse events, like pressed and released. They worked fine, when I used them in the InputSystem MouseTests. Now when I put them into my project the application starts and quits immideatly. I only see the application window flickering up. When starting the Application without Debug I got the following error from the JIT debugger:

Informationen über das Aufrufen von JIT-Debuggen
anstelle dieses Dialogfelds finden Sie am Ende dieser Meldung.

************** Ausnahmetext **************
System.TypeLoadException: Der Typ "Delta.Engine.Screen" in der Assembly "Delta.Engine, Version=, Culture=neutral, PublicKeyToken=null" konnte nicht geladen werden.
   bei Delta.InputSystem.Windows.WindowsMouse.Qxa6wGRRJKsKvmeYPiU(Point )
   bei Delta.InputSystem.Windows.WindowsMouse.inrwd1PS4(Object , MouseEventArgs )
   bei System.Windows.Forms.Control.OnMouseMove(MouseEventArgs e)
   bei System.Windows.Forms.Control.WmMouseMove(Message& m)
   bei System.Windows.Forms.Control.WndProc(Message& m)
   bei System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   bei System.Windows.Forms.Form.WndProc(Message& m)
   bei Delta.Platforms.Windows.NativeMessageForm.WndProc(Message& m)
   bei System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   bei System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   bei System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

Wanna join the discussion?! Login to your forum accountregister a new account. Or Connect via Facebook Twitter Google

Offline Robert Walter  
#2 Posted : Tuesday, November 15, 2011 5:43:49 PM(UTC)
Robert Walter

Joined: 8/24/2011(UTC)
Posts: 68

Thanks: 4 times
I integrated the code now into another project of mine and now it works. Dunno, what was wrong in the first place oO
Offline Benjamin  
#3 Posted : Monday, November 21, 2011 2:51:55 AM(UTC)

Medals: Admin

Joined: 8/20/2011(UTC)
Posts: 1,421
Location: Hannover

Thanks: 18 times
Was thanked: 97 time(s) in 92 post(s)
I guess you had a version mismatch error. In v0.9.1 this was improved and should hopefully not happen anymore.
Rss Feed  Atom Feed
Users browsing this topic
OceanSpiders 2.0
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2023, Yet Another Forum.NET
This page was generated in 0.362 seconds.