Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Offline mc-kay  
#1 Posted : Friday, May 31, 2013 1:36:20 PM(UTC)
mc-kay

Medals: Admin

Joined: 8/24/2011(UTC)
Posts: 138
Location: Hannover

Thanks: 1 times
Was thanked: 12 time(s) in 7 post(s)
The second sprint release of the Milestone 4 Saturn series was just released and pushed to NuGet, GitHub and CodePlex.
Changelog: http://deltaengine.net/Milestone/4#4
Download: http://DeltaEngine.net/Download
thanks 3 users thanked mc-kay for this useful post.
internetfreak on 5/31/2013(UTC), Old Sparky on 5/31/2013(UTC), fg_garda on 5/31/2013(UTC)

Wanna join the discussion?! Login to your forum accountregister a new account. Or Connect via Facebook Twitter Google

Offline fg_garda  
#2 Posted : Monday, June 3, 2013 12:37:22 AM(UTC)
fg_garda

Joined: 3/18/2013(UTC)
Posts: 29

Thanks: 5 times
Hallo, for the DeltaEngine.Samples solution I got these warnings:

Code:

Warning	1  The referenced project '..\..\Graphics\BaseOpenGL\DeltaEngine.Graphics.BaseOpenGL.csproj' does not exist.        DeltaEngine.WindowsOpenTK
Warning	2  The referenced project '..\..\Multimedia\BaseOpenAL\DeltaEngine.Multimedia.BaseOpenAL.csproj' does not exist.    DeltaEngine.WindowsOpenTK
Warning	3  The referenced project '..\..\Graphics\BaseOpenGL\DeltaEngine.Graphics.BaseOpenGL.csproj' does not exist.        DeltaEngine.Multimedia.OpenTK
Warning	4  The referenced project '..\..\Multimedia\BaseOpenAL\DeltaEngine.Multimedia.BaseOpenAL.csproj' does not exist.    GameOfDeath
Warning	5  The referenced component 'DeltaEngine.Graphics.BaseOpenGL' could not be found.                                   DeltaEngine.WindowsOpenTK
Warning	6  The referenced component 'DeltaEngine.Multimedia.BaseOpenAL' could not be found.                                 DeltaEngine.WindowsOpenTK
Warning	7  The referenced component 'DeltaEngine.Graphics.BaseOpenGL' could not be found.                                   DeltaEngine.Multimedia.OpenTK
Warning	8  The referenced component 'DeltaEngine.Multimedia.BaseOpenAL' could not be found.                                 GameOfDeath



In fact GameOfDeath doesn't start for a "openal32.dll not found" error. I had to copy that file manually: in the version 0.9.8.0 there was a post build macro for this job. Is this correct?

Same problems with the DeltaEngine.sln for the WindowsOpenTK and Multimedia.OpenTK projects.

For your information I report also that I got these errors for the DeltaEngine.Editor.Launcher.Tests project:

Code:

Error	2	Unable to find version '10.1.40219.425' of package 'Microsoft.Smartdevice.Connectivity'.	
Error	3	The command ""C:\DeltaEngine\Editor\.nuget\nuget.exe" install "C:\DeltaEngine\Editor\Launcher\Tests\packages.config" -source ""  -RequireConsent -o "C:\DeltaEngine\Editor\packages"" exited with code 1.
Warning	4	The referenced component 'ApprovalTests' could not be found.
Warning	5	The referenced component 'ApprovalUtilities' could not be found.
Warning	6	The referenced component 'GalaSoft.MvvmLight.WPF4' could not be found.
Warning	7	The referenced component 'Microsoft.Smartdevice.Connectivity' could not be found.
Warning	8	The referenced component 'NCrunch.Framework' could not be found.
Warning	9	The referenced component 'nunit.framework' could not be found.
Warning	10	The referenced component 'PresentationCore' could not be found.
Warning	11	The referenced component 'PresentationFramework' could not be found.
Warning	12	The referenced component 'System' could not be found.
Warning	13	The referenced component 'System.Xaml' could not be found.
Warning	14	The referenced component 'WindowsBase' could not be found.


Anyway, I can proceed by following this post

Thanks.
Offline Old Sparky  
#3 Posted : Monday, June 3, 2013 4:21:03 PM(UTC)
Old Sparky

Joined: 10/7/2012(UTC)
Posts: 15

Thanks: 2 times
Was thanked: 2 time(s) in 2 post(s)
Hello,

The DeltaEngine.Scenes reference is not automatically included (v.0.9.8.1), if the references are added with NuGet (DeltaEngine.OpenTk, DeltaEngine.XNA, DeltaEngine.SharpDX).

Could you please fix the NuGet packages?

Thanks Smile

PS: The DeltaEngine.XNA package is in version 0.9.8.0. It should also be updated.

Edited by user Monday, June 3, 2013 4:23:19 PM(UTC)  | Reason: Not specified

Offline mc-kay  
#4 Posted : Tuesday, June 4, 2013 11:45:35 AM(UTC)
mc-kay

Medals: Admin

Joined: 8/24/2011(UTC)
Posts: 138
Location: Hannover

Thanks: 1 times
Was thanked: 12 time(s) in 7 post(s)
Thanks fg_garda and Old Sparky for your feedback, we'll investigate into the reported issues.
I also uploaded the missing DeltaEngine.XNA package Smile
Rss Feed  Atom Feed
Users browsing this topic
OceanSpiders 2.0
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2017, Yet Another Forum.NET
This page was generated in 0.053 seconds.