Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Offline aarnoutvo  
#1 Posted : Monday, April 14, 2014 1:11:20 PM(UTC)
aarnoutvo

Joined: 4/11/2013(UTC)
Posts: 3

Thanks: 1 times
Hi,

First of all, I would like to say: Great work so far on the Engine. I have been using it for a year or so and I am very impressed with the features that are getting added all the time.

I do, however, run into an issue recently with the Editor.

Since installing DeltaEngine 1.1 from the download page, I am having issues uploading content to my project, using the DeltaEngine editor.

• I am running Windows 8.1, but have also gone through the same workflow on a clean Windows 7 PC
• Development is done on Visual Studio 2012 Express
• I am generally starting the Editor via the OpenTK version
• My project is created as an OpenTK project and using the EmptyApp Template

I normally use the installer to installer on the download page, but for this purpose I have also tried the latest (?) nightly build (16 March). Perhaps the version I am using is already a clue? Smile

Generally, I am getting the following error:

Server Error: Command ‘filemd5’ failed: exception: Can’t get runner for query {Files_id: ObjectId(‘534bbaccc204c60b88103b96’), n: {$gte:0}}(response: {“errmsg”:”exception: Can’t get runner for query {files_id: ObjectId(‘534bbaccc204c60b88103b96’), n:{$gte:0}}”,”code”:17241, “ok”:0.0})

I have tried the following:

Delete all my projects in the Editor -> Close the Editor -> Delete the folder c:\users\<my username>\documents\deltaengine -> Start the Editor -> Create a new project -> Use the ‘New’ or ‘Import’ button to get Content into my project

Other errors also come into play, like this one, on the server log:

System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> DeltaEngine.Input.KeyTrigger+CannotCreateKeyTriggerWithoutKey: Exception of type 'DeltaEngine.Input.KeyTrigger+CannotCreateKeyTriggerWithoutKey' was thrown. at DeltaEngine.Input.KeyTrigger..ctor(String keyAndState) --- End of inner exception stack trace --- at DeltaEngine.Commands.Trigger.GenerateTriggerFromType(Type triggerType, String triggerName, String triggerValue).

Note that I have reinstalled several times on 2 different machines.

Any help/suggestions/potential fixes are very welcome!

Thank you!

Aarnout

Wanna join the discussion?! Login to your forum accountregister a new account. Or Connect via Facebook Twitter Google

Offline Benjamin  
#2 Posted : Monday, April 14, 2014 4:03:38 PM(UTC)
Benjamin

Medals: Admin

Joined: 8/20/2011(UTC)
Posts: 1,421
Location: Hannover

Thanks: 18 times
Was thanked: 97 time(s) in 92 post(s)
Hi aarnoutvo,

funny you get so much details of the error. It happens on the server side and we are aware of it. Somehow our old database file system access broken down (it is a known issue with the software we used), we were hoping to get the new system up and running by the end of last week, but due to sickness in our content team the work could not be finished. Now it probably makes sense to first fix the old system and then work on the new one.

Long story short, tomorrow things should hopefully work again, sorry for the inconvenience and thanks for the error report. In the meantime simply use DiskContentLoader in the first line of code of your app to get to your existing content you already have on disk (in \bin\Debug\Content\<ProjectName>\):
Code:

ContentLoader.Use<DiskContentLoader>();

thanks 1 user thanked Benjamin for this useful post.
aarnoutvo on 4/14/2014(UTC)
Offline aarnoutvo  
#3 Posted : Monday, April 14, 2014 4:58:23 PM(UTC)
aarnoutvo

Joined: 4/11/2013(UTC)
Posts: 3

Thanks: 1 times
Hi Benjamin,

Thank you very much for the quick reply and the tip on using the DiskContentLoader.

Best wishes and good luck with the further development. Great to see how things are shaping up.

Aarnout
Offline Benjamin  
#4 Posted : Tuesday, April 15, 2014 4:01:55 PM(UTC)
Benjamin

Medals: Admin

Joined: 8/20/2011(UTC)
Posts: 1,421
Location: Hannover

Thanks: 18 times
Was thanked: 97 time(s) in 92 post(s)
Hi Aarnout,

The upload issue has been fixed, had to look into the issue myself as the content service expert is still sick. You should be able to use the 1.1 Editor or the nightly release version to download and upload any supported content once again. Keep in mind we are currently changing the system and will replace the way content is stored and uploaded in the upcoming week. For you nothing changes (maybe some calls to ContentLoader.Load are replaced with Scene.GetFile instead, but if you just use high level objects like Sprite, Button, etc. not much will change for you).

Hope this helps. Let me know if you run in any other trouble. Thanks.
Offline aarnoutvo  
#5 Posted : Wednesday, April 16, 2014 8:48:18 AM(UTC)
aarnoutvo

Joined: 4/11/2013(UTC)
Posts: 3

Thanks: 1 times
Hi Benjamin,

Thank you for taking care of this. I can confirm that uploads are working for me again, which is great news. I'll keep your upgrade to the new system in mind, over the next couple of weeks.

Best wishes,

Aarnout



Rss Feed  Atom Feed
Users browsing this topic
OceanSpiders 2.0, Yandex
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2018, Yet Another Forum.NET
This page was generated in 0.116 seconds.