Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Offline Crasher  
#1 Posted : Sunday, September 25, 2011 5:05:16 PM(UTC)
Crasher

Joined: 8/29/2011(UTC)
Posts: 2

I compiled the DeltaEngine solution and tried to run a sample game. In login dialog, I entered my user name and password (for my profile account).
After clicking OK, I got an error message:
Unable to connect to server (are you offline?) Please correct your input and try again.

Does it mean a server is down? If so, what server? What account should I use? I have full access to my profile and forum, as I write this.
Does it mean I need access to a cloud service?

Wanna join the discussion?! Login to your forum accountregister a new account. Or Connect via Facebook Twitter Google

Offline zato_1one  
#2 Posted : Sunday, September 25, 2011 5:20:04 PM(UTC)
zato_1one

Joined: 8/21/2011(UTC)
Posts: 61

Thanks: 1 times
Was thanked: 1 time(s) in 1 post(s)
Try spamming the OK button until it passes the login window. It works for me.

The account is the same account you use here.
Offline Crasher  
#3 Posted : Sunday, September 25, 2011 6:46:23 PM(UTC)
Crasher

Joined: 8/29/2011(UTC)
Posts: 2

Originally Posted by: zato_1one Go to Quoted Post
Try spamming the OK button until it passes the login window. It works for me.

The account is the same account you use here.


Thanks for the answer... It didn't work for me. I've changed startup projects a couple of times (Blocks and Pong), and now,
after clicking through exceptions it shows a dialog that says no content found on server.
Clicking OK raises an exception "The process cannot access the file" when it tries to copy the file
C:\Delta Physics Engine\Utilities\Xml\bin\Release\Delta.Utilities.Xml.dll to the destination:
C:\Delta Physics Engine\Samples\Pong\bin\Release\Delta.Utilities.Xml.dll

It happens inside a call to Material2D constructor.
I found this article: http://exdream.com/Blog/...or-in-Visual-Studio.aspx
by Benjamin Nitschke
and tried to add macros suggested and remove .locked files from projects. This allowed me to get further in the chain of exceptions, but now I am stuck with another one (a short excerpt from the full report):

CreateInstance failed for 'Delta.Graphics.OpenTK.OpenTKShader': Exception has been thrown by the

target of an invocation. Inner Exception: Unable to find an entry point named 'glGetUniformLocation' in DLL

'opengl32.dll'.
This means the dynamic creation of 'Delta.Graphics.OpenTK.OpenTKShader' worked, but the class failed

internally and the instance could not be created (there should be a previous error, if not, try to debug the

constructor of the class!)
System.EntryPointNotFoundException: Unable to find an entry point named

'glGetUniformLocation' in DLL 'opengl32.dll'.


This looks like a more serious error (bug).
File Attachment(s):
Pong error.txt (43kb) downloaded 2 time(s).

You cannot view/download attachments. Try to login or register.
Offline Benjamin  
#4 Posted : Monday, September 26, 2011 12:17:22 AM(UTC)
Benjamin

Medals: Admin

Joined: 8/20/2011(UTC)
Posts: 1,421
Location: Hannover

Thanks: 18 times
Was thanked: 97 time(s) in 92 post(s)
Well, the v0.8.6 server was updated to v0.9.0 and will not longer accept beta client users. I can restart the old version in case anyone still needs it, but checking from the logs there was not much going on the last week. If you want to you try again, the v0.8.6 server is now up again, but it will be replaced in the next few days once we go to final testing.
Offline Benjamin  
#5 Posted : Monday, September 26, 2011 12:18:43 AM(UTC)
Benjamin

Medals: Admin

Joined: 8/20/2011(UTC)
Posts: 1,421
Location: Hannover

Thanks: 18 times
Was thanked: 97 time(s) in 92 post(s)
Originally Posted by: Benjamin Nitschke (DeltaEngine) Go to Quoted Post
Well, the v0.8.6 server was updated to v0.9.0 and will not longer accept beta client users. I can restart the old version in case anyone still needs it, but checking from the logs there was not much going on the last week. If you want to you try again, the v0.8.6 server is now up again, but it will be replaced in the next few days once we go to final testing.


Ohh and by the way, if you have no connection in v0.8.6.1 it does not really matter because if you abort the login dialog the fallback content will be loaded locally and the samples should still work.
Offline Benjamin  
#6 Posted : Sunday, March 11, 2012 11:49:14 AM(UTC)
Benjamin

Medals: Admin

Joined: 8/20/2011(UTC)
Posts: 1,421
Location: Hannover

Thanks: 18 times
Was thanked: 97 time(s) in 92 post(s)
Originally Posted by: Crasher Go to Quoted Post

System.EntryPointNotFoundException: Unable to find an entry point named 'glGetUniformLocation' in DLL 'opengl32.dll'.


I case anyone encounters this problem in the future with any OpenTK or in fact OpenGL application (has not much to do with the Delta Engine itself), just make sure you have up to date graphic drivers. I updated my system to Windows 8 yesterday and the AMD Catalyst drivers did not fully work after the update, but I ignored the warning from Windows and let it use the fallback drivers. However, when starting any OpenGL application using shaders I got the above error. After updating the AMD Catalyst driver (or Nvidia driver on my notebook), all the problems have gone away:

General graphic driver links:
http://www.nvidia.com/Download/index.aspx
http://support.amd.com/u...ownload/Pages/index.aspx

Windows 8 Consumer Preview graphic drivers:
http://www.nvidia.com/ob...-295.73-whql-driver.html
http://support.amd.com/u...sumerPreviewDrivers.aspx

Hope this helps if someone stumbles to this post (there was not much to find when searching Bing or Google for this issue).
Rss Feed  Atom Feed
Users browsing this topic
OceanSpiders 2.0
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2018, Yet Another Forum.NET
This page was generated in 0.143 seconds.